Integrator > Synchronize user data with EPIC > Install and run the EPIC client > Upgrading the EPIC client from a previous version

Upgrading the EPIC client from a previous version

This article explains the steps to upgrade to the latest version of the EPIC client. You should upgrade to the latest version of the EPIC client to ensure that is compatible with xMatters On-Demand and that it can access the latest features that have been deployed on your system.

See EPIC client system requirements to review the system requirements for the EPIC client.